Re: [PATCH] checkpatch: consolidate if (foo) bar(foo) checks andadd debugfs_remove

From: Joe Perches
Date: Tue Nov 20 2012 - 13:37:18 EST


On Tue, 2012-11-20 at 16:39 +0000, Andy Whitcroft wrote:
> On Tue, Nov 20, 2012 at 07:51:17AM -0800, Joe Perches wrote:
> > On Tue, 2012-11-20 at 15:37 +0000, Andy Whitcroft wrote:
> > > Consolidate the if (foo) bar(foo) detectors into a single check. Add
> > > debugfs_remove and family.
> > >
> > > Based on a patch by Constantine Shulyupin <const@xxxxxxxxxxxxx>.
> > []
> > > diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
> > []
> > >
> > > +# check for needless "if (<foo>) fn(<foo>)" uses
> > > + if ($prevline =~ /\bif\s*\(\s*($Lval)\s*\)/) {
> > > + my $expr = '\s*\(\s*' . quotemeta($1) . '\s*\)\s*;';
> > > +
> > []
> > > +# check for needless debugfs_remove() and debugfs_remove_recursive*() checks
> >
> > Hey Andy, that's an incomplete comment.
> > Just remove it.
>
> Oh it is meant to drop next to the other comments from the preceeding
> hunks which are being removed, it should end up looking like this:
>
> # check for needless kfree() checks
> # check for needless usb_free_urb() checks
> # check for needless debugfs_remove() and debugfs_remove_recursive*() checks
>
> Admitedly the trailing checks on each are a little redundant, but it is
> intended to retain the list of functions affected.

I think all of those are unnecessary.
Self documenting code is better right?

If not, I'd remove the "check for needless", leave the function,
and remove the trailing "checks"

btw: the * after debugfs_remove_recursive should be removed too.

cheers, Joe

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/