Re: [PATCH v4 3/3] cred: change keyctl_session_to_parent() to use task_work_add()

From: David Howells
Date: Tue Apr 17 2012 - 10:23:15 EST

Oleg Nesterov <oleg@xxxxxxxxxx> wrote:

> - int ret;
> + struct cred *cred;
> + int err;

There's no need to change ret to be err. It produces slightly less churn if
you don't.

> + err = -ENOMEM;
> + newwork = kmalloc(sizeof(struct task_work), GFP_KERNEL);
> + if (!newwork)
> + goto error_keyring;

This passes unnecessarily through kfree(newwork). Please add a new goto label
and go to that.

> -/*
> - * Replace a process's session keyring on behalf of one of its children when
> - * the target process is about to resume userspace execution.
> - */

Please don't delete the banner comment saying what the function does.

> -void key_replace_session_keyring(void)
> +void key_change_session_keyring(struct task_work *twork)

There's no particular need to change the name of the function.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at