Re: [PATCH 1/8] KVM: MMU: combine unsync and unsync_children

From: Takuya Yoshikawa
Date: Sun Dec 18 2011 - 21:24:31 EST


About naming issues in the kvm mmu code.

Not restricted to your patch series, so please take as a suggestion
for the future.

(2011/12/16 19:13), Xiao Guangrong wrote:
+static bool sp_is_unsync(struct kvm_mmu_page *sp)
+{
+ return sp->role.level == PT_PAGE_TABLE_LEVEL&& sp->unsync;
+}

is_unsync_sp() is more consistent with others?
e.g. is_large_pte(), is_writable_pte(), is_last_spte()


Takuya

+
+static unsigned int sp_unsync_children_num(struct kvm_mmu_page *sp)
+{
+ unsigned int num = 0;
+
+ if (sp->role.level != PT_PAGE_TABLE_LEVEL)
+ num = sp->unsync_children;
+
+ return num;
+}
+
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/