Re: [PATCH 00/11] RFC spi-dw updates

From: Feng Tang
Date: Wed Jun 22 2011 - 22:32:09 EST


Hi Dirk,

On Thu, 23 Jun 2011 10:00:02 +0800
"dirk.brandewie@xxxxxxxxx" <dirk.brandewie@xxxxxxxxx> wrote:

> From: Dirk Brandewie <dirk.brandewie@xxxxxxxxx>
>
> This patch set contains a number of changes were buried inside of one
> large patch in my last patch set. The rework of the message/transfer
> handling changes are not part of this patch set.
>
>
> This patch set applies after commit ca632f5 on spi/next
>
>
> Dirk Brandewie (11):
> spi-dw: expose platform data stucture.
> spi-dw: update function naming convention to match file naming
> spi-dw: change MRST prefix to generic prefix
> spi-dw: remove unused definition
> spi-dw: split spi_dw_enable_chip() into
> spi_dw_enable()/spi_dw_disable() spi-dw: Force error on out of range
> chip select. spi-dw: Set number of available chip selects correctly
> spi-dw: Ensure fifo lenght is set.
> spi-dw: Fix condition in spi_dw_{writer/reader}
> spi-dw: Move checking of max_speed_hz value to be a prerequisite in
> spi_dw_setup spi-dw: remove noop else clause

Most of the patches looks good to me, I'll reply to the rest separately.

Thanks,
Feng

>
> drivers/spi/spi-dw-mid.c | 30 +++---
> drivers/spi/spi-dw-mmio.c | 38 ++++----
> drivers/spi/spi-dw-pci.c | 34 +++---
> drivers/spi/spi-dw.c | 247
> ++++++++++++++++++++------------------------
> drivers/spi/spi-dw.h | 82 ++++++---------
> include/linux/spi/spi-dw.h | 42 ++++++++ 6 files changed, 241
> insertions(+), 232 deletions(-) create mode 100644
> include/linux/spi/spi-dw.h
>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/