Re: [PATCH -v3 1/6] x86, MCE: Add a HW injection flag

From: Hidetoshi Seto
Date: Mon May 09 2011 - 23:30:15 EST


(2011/05/10 3:35), Borislav Petkov wrote:
> From: Borislav Petkov <borislav.petkov@xxxxxxx>
>
> Add an mce->inject_flag to denote that we're doing HW injection.
>
> Signed-off-by: Borislav Petkov <borislav.petkov@xxxxxxx>
> Acked-by: Ingo Molnar <mingo@xxxxxxx>
> ---
> arch/x86/include/asm/mce.h | 1 +
> 1 files changed, 1 insertions(+), 0 deletions(-)
>
> diff --git a/arch/x86/include/asm/mce.h b/arch/x86/include/asm/mce.h
> index eb16e94..a2e3dcf 100644
> --- a/arch/x86/include/asm/mce.h
> +++ b/arch/x86/include/asm/mce.h
> @@ -49,6 +49,7 @@
> #define MCJ_CTX_IRQ 2 /* inject context: IRQ */
> #define MCJ_NMI_BROADCAST 4 /* do NMI broadcasting */
> #define MCJ_EXCEPTION 8 /* raise as exception */
> +#define MCJ_HW_INJECT 16 /* do a HW MCE inject, i.e. INT18 */
>
> /* Fields are zero when not available */
> struct mce {

IMHO, we should have better name for this feature; using wrmsr + int$18 is not
the only way to inject mce event to HW. I'd like to suggest MCJ_AMD_HW_INJECT,
MCJ_USE_WRMSR or so instead. Then we can have MCJ_USE_APEI_EINJ and so on, for
various way of MCE injection.


Thanks,
H.Seto




--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/