Re: [PATCH] m68knommu: change definitions of __pa() and __va()

From: Linus Torvalds
Date: Mon Jan 11 2010 - 19:54:14 EST




On Tue, 12 Jan 2010, Greg Ungerer wrote:
> +#else
> +#define page_to_phys(page) ((page - mem_map) << PAGE_SHIFT)
> +#define page_to_bus(page) ((page - mem_map) << PAGE_SHIFT)
> +#endif

Ok, so the old ones were total crap too, but when moving things around,
don't just copy the crap like this.

Look at those two #define's for five seconds, and ask yourself what is
wrong with them. Those macros are not good.

Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/