Re: [PATCH] ep93xx_eth.c: general cleanup

From: Joe Perches
Date: Wed Dec 16 2009 - 12:32:28 EST


On Wed, 2009-12-16 at 12:09 -0500, H Hartley Sweeten wrote:
> +#define pr_fmt(fmt) KBUILD_MODNAME ": %s: " fmt, __func__

I think KBUILD_MODNAME ":%s: " fmt, __func__
or its equivalent direct use is more common.
It's possibly useful to standardize.

> -#define DRV_MODULE_NAME "ep93xx-eth"
> -#define DRV_MODULE_VERSION "0.1"
> +#include <mach/hardware.h>

I think these sorts of defines are common and useful.

> static int __init ep93xx_eth_init_module(void)
> {
> - printk(KERN_INFO DRV_MODULE_NAME " version " DRV_MODULE_VERSION " loading\n");

Why remove this printk completely?


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/