Re: [PATCH] mtd: fix mtd_blkdevs problem with caches on somearchitectures (2.6.31)

From: David Woodhouse
Date: Sun Nov 22 2009 - 04:54:20 EST


On Sun, 2009-11-22 at 12:46 +0300, Ilya Loginov wrote:
>
> +#define ARCH_IMPLEMENTS_FLUSH_DCACHE_PAGE 0
> #define flush_dcache_page(page) do { } while (0)
> #define flush_dcache_mmap_lock(mapping) do { } while (0)
> #define flush_dcache_mmap_unlock(mapping) do { } while (0)

The thing is, having a function called flush_dcache_page() which doesn't
actually flush a page of the dcache is just blatantly stupid.

It's misnamed -- it should probably be called something like
'flush_valiased_dcache_page()' or 'unalias_dcache_page()' instead, since
I believe it's only supposed to cope with aliasing issues with virtually
indexed caches.

If you're talking about _extending_ the existing silly name to a new
ARCH_IMPLEMENTS_FOO macro or Kconfig option, perhaps this would be a
good time to fix the nomenclature, rather than propagating the error?

--
David Woodhouse Open Source Technology Centre
David.Woodhouse@xxxxxxxxx Intel Corporation

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/