Re: [PATCH v2 1/6] ACPI: dock: clean up error handling paths indock_add()

From: Dmitry Torokhov
Date: Fri Oct 16 2009 - 00:37:47 EST


Hi Alex,

On Wed, Oct 14, 2009 at 04:46:16PM -0600, Alex Chiang wrote:
> Remove some copy/paste code in our error handling paths, which makes
> the function smaller and slightly easier to read.

Changing individual attributes into attribute_group would greatly
simplify the code.

>
> Signed-off-by: Alex Chiang <achiang@xxxxxx>
> ---
>
> drivers/acpi/dock.c | 75 +++++++++++++++++++--------------------------------
> 1 files changed, 28 insertions(+), 47 deletions(-)
>
> diff --git a/drivers/acpi/dock.c b/drivers/acpi/dock.c
> index 7338b6a..642c7dd 100644
> --- a/drivers/acpi/dock.c
> +++ b/drivers/acpi/dock.c
> @@ -968,11 +968,9 @@ static int dock_add(acpi_handle handle)
> platform_device_register_simple(dock_device_name,
> dock_station_count, NULL, 0);
> dock_device = dock_station->dock_device;
> - if (IS_ERR(dock_device)) {
> - kfree(dock_station);
> - dock_station = NULL;
> - return PTR_ERR(dock_device);
> - }
> + ret = IS_ERR(dock_device) ? PTR_ERR(dock_device) : 0;
> + if (ret)
> + goto out;

I think

if (IS_ERR(dock_device)) {
ret = PTR_ERR(dock_device);
goto out;
}

is more commonly used form.

Thanks.

--
Dmitry
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/