Re: [PATCH 1/1] VIDEO: console, use DIV_ROUND_UP

From: Sergey Senozhatsky
Date: Mon Aug 17 2009 - 03:57:08 EST


On (08/17/09 09:48), Jiri Slaby wrote:
> On 08/17/2009 09:31 AM, Sergey Senozhatsky wrote:
> > On (08/17/09 09:15), Jiri Slaby wrote:
> >> Not at all. I was writing about about (X + 7) / 8 [or >> 3] which is
> >> DIV_ROUND_UP(X, 8).
> >>
> > As far as I can understand:
> > DIV_ROUND_UP(61, 8):
> > (111101 + 111) >> 3 -> 1000 == 8
> >
> > (int)(61/8) == 7
>
> Yeah, that's why there is the ROUND_UP keyword in the macro.
>
> I mean this:
> --
> Use DIV_ROUND_UP explicitly instead of manual shifts and adds. It makes
> the code more readable and consistent (sometimes there were shifts,
> sometimes divs).
>
> There is no change on the assembly level (compilers should do the right
> job).
>
> Signed-off-by: Jiri Slaby <jirislaby@xxxxxxxxx>
> ---
> drivers/video/console/bitblit.c | 8 ++++----
> 1 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/video/console/bitblit.c b/drivers/video/console/bitblit.c
> index 69864b1..6b7c8fb 100644
> --- a/drivers/video/console/bitblit.c
> +++ b/drivers/video/console/bitblit.c
> @@ -25,7 +25,7 @@ static inline void update_attr(u8 *dst, u8 *src, int attribute,
> struct vc_data *vc)
> {
> int i, offset = (vc->vc_font.height < 10) ? 1 : 2;
> - int width = (vc->vc_font.width + 7) >> 3;
> + int width = DIV_ROUND_UP(vc->vc_font.width, 8);

So... In general, ((vc->vc_font.width + 7) >> 3) == DIV_ROUND_UP(vc->vc_font.width, 8) - 1;
That means:
unsigned int cellsize = vc->vc_font.height * width; now is unsigned int cellsize = vc->vc_font.height * (width + 1);

Are you sure we really can use DIV_ROUND_UP?

Sergey

Attachment: signature.asc
Description: Digital signature