Re: [PATCH v2 1/2] tracing/events: make __string() more general

From: Li Zefan
Date: Tue May 26 2009 - 22:32:43 EST


>> Ah, it's pseudo code.. Should be construct_str(__entry->cmd, rq),
>> this helper function convert rq->cmd (unsigned char[]) to a string of
>> hex dump.
>>
>> No source string is available, so I'm not calling assign_str() in
>> TP_fast_assign.
>
> OK, I think I have a better understanding of what you are doing.
>
> But, I don't like changing the interface for string by adding that
> "strlen" to all users. I find that very ugly.
>

Yeah, it does look somewhat ugly..

> Could we instead perhaps add a __dynamic_array? That would take a length,
> and append itself to after the strings?
>

I thought about this actually. ;)

What troubled me is to give this new macro a better name.

We have __array() which is fixed-size, but __dynamic_array() is not
a dynamic-size version of __array(). How about __dyn_string() or
__dynamic_string()?

> stage 1:
>
> #define __dynamic_array(item, len) int __dyn_loc_##item;
>
> stage 2:
>
> #define __dynamic_array(item, len) int item;
>
> stage 3:
>
> #define __get_dynamic_array(item) \
> ((void *)__entry + __entry->__str_loc_##field
>
> stage 4:
>
> #define __dynamic_array(item, len) \
> __str_offsets.item = __str_size + \
> offsetof(typeof(*entry), __str_data); \
> __str_size += len;
>

Then we can make __string() reuse __dynamic_array().

>
> And so on. You should be able to do something like this, and make it more
> generic.
>

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/