Re: [patch] security: rename ptrace_may_access =>ptrace_access_check

From: Oleg Nesterov
Date: Thu May 07 2009 - 05:29:28 EST


On 05/07, Ingo Molnar wrote:
>
> * Ingo Molnar <mingo@xxxxxxx> wrote:
> Subject: security: rename ptrace_may_access => ptrace_access_check
> From: Ingo Molnar <mingo@xxxxxxx>
>
> The ->ptrace_may_access() methods are named confusingly - the real
> ptrace_may_access() returns a bool, while these security checks have
> a retval convention.
>
> Rename it to ptrace_access_check, to reduce the confusion factor.

Great. Now we can rename (and fix the callers of) ptrace.c:ptrace_may_access()
accordingly.

But,

> -static inline int security_ptrace_may_access(struct task_struct *child,
> +static inline int security_ptrace_access_check(struct task_struct *child,
> unsigned int mode)

You seem to forgot to update the callers of this helper.

Oleg.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/