Re: [FOR REVIEW, PATCH 2/2] introduce "struct wait_opts" tosimplify do_wait() pathes

From: Oleg Nesterov
Date: Thu May 07 2009 - 02:45:30 EST


On 05/06, Ingo Molnar wrote:
>
> One small nit with the definition above: when using vertical spacing
> (which really looks nice) we tend to put the asterix to the type
> itself, not to the variable. I.e.:
>
> enum pid_type wtype;
> struct pid * wpid;
> int wflags;
>
> ( This is done to separate the field name from the type - the
> pointer nature of the field is part of the type, not part of the
> name. )

Indeed, I like this more too. But checkpatch.pl disagrees!

> it makes sense to write this as:
>
> > + wopts.wtype = type;
> > + wopts.wpid = pid;
> > + wopts.wflags = options;
> > +
> > + wopts.winfo = infop;
> > + wopts.wstat = NULL;
> > + wopts.wrusage = ru;
> > +
> > + ret = do_wait(&wopts);
>
> (and in other places as well). Vertical spacing for assignments
> looks messy if done for 1-3 assignment lines, but in the case above
> we've got 6 of them so it has a nice vertical structure already that
> helps readability.

Done.

> Regarding the patch itself: i guess we could do it as-is - but if
> you think there's regression risks, a safer approach would be to
> create 5-6 patches to build up all the structure parameters one by
> one.

Oh, I tried to do it this way first. But I got lost and decided to
make a single patch. Besides, if I make 6 patches I should try to test
each one...

> Anyway ... provided you give it some testing:

Well, I did now. But of course this needs more testing. As you see,
the patch is trivial, it "must" be correct. Except some silly typos
are possible.

> Reviewed-by: Ingo Molnar <mingo@xxxxxxx>

Thanks!

Oleg.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/