Re: [PATCH] fs: add roundup_to_blocksize and bytes_to_blocks helperfunctions

From: Andrew Morton
Date: Wed Apr 22 2009 - 17:12:34 EST


On Sun, 19 Apr 2009 20:42:15 +0200
Marcin Slusarz <marcin.slusarz@xxxxxxxxx> wrote:

> bytes_to_blocks is open coded in more than 30 places
> roundup_to_blocksize is open coded in more than 15 places
>

It would be nice to document these a bit. Kernel-wide helpers..

> ---
> include/linux/fs.h | 12 ++++++++++++
> 1 files changed, 12 insertions(+), 0 deletions(-)
>
> diff --git a/include/linux/fs.h b/include/linux/fs.h
> index e766be0..1b4e5b6 100644
> --- a/include/linux/fs.h
> +++ b/include/linux/fs.h
> @@ -2451,5 +2451,17 @@ int proc_nr_files(struct ctl_table *table, int write, struct file *filp,
>
> int get_filesystem_list(char * buf);
>
> +static inline
> +unsigned long long roundup_to_blocksize(unsigned long long bytes, struct super_block *sb)
> +{
> + return (bytes + sb->s_blocksize - 1) & ~(sb->s_blocksize - 1);

This is ALIGN(bytes, sb->s_blocksize). Dunno if that's any clearer though.

> +}
> +
> +static inline
> +blkcnt_t bytes_to_blocks(unsigned long long bytes, struct super_block *sb)
> +{
> + return (bytes + sb->s_blocksize - 1) >> sb->s_blocksize_bits;
> +}

I wonder whether `unsigned long long' was the best choice of type here.

Probably `bytes' should be loff_t.

roundup_to_blocksize() could/should return loff_t too, I think.

roundup_to_blocksize() isn't a terribly good name, IMO. The name
conveys no sense of what the function returns. It _sounds_ like it
returns a "block size". But it doesn't - it returns a loff_t.
round_up_file_offset_to_block_size() is a bit long though :(


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/