Re: [PATCH 00/30] C/R OpenVZ/Virtuozzo style

From: Ingo Molnar
Date: Tue Apr 14 2009 - 09:45:38 EST



* Alexey Dobriyan <adobriyan@xxxxxxxxx> wrote:

> On Mon, Apr 13, 2009 at 11:39:51AM -0700, Linus Torvalds wrote:
> >
> >
> > On Mon, 13 Apr 2009, Alexey Dobriyan wrote:
> > >
> > > Well, in OpenVZ everything is in kernel/cpt/ and prefixed with "cpt_"
> > > and "rst_".
> >
> > So?
> >
> > We're not merging OpenVZ code _either_.
>
> This is to give example of other prefixes: cpt_ and rst_
> Are they fine?

Not really. 'rst' can be easily mistaken for 'reset' and neither
really tells me at a glance what they do. They are also quite
tongue-twisters.

See my namespace analysis and suggestions from yesterday for a
proper naming scheme.

The key i believe is to move away from this singular 'the world is
all about checkpoint and restore', and move it to a IMHO clearer
state_*() type of naming which really isolates all these kernel
state save/restore management APIs from other kernel APIs. (See my
mail from yesterday for details.)

kstate_*() would be another, perhaps even clearer naming scheme.
I.e.:

kstate_checkpoint_XYZ()
kstate_restore_XYZ()
kstate_collect_XYZ()
kstate_dump_XYZ()
kstate_image_XYZ()
...

Just _look_ at them - they are expressive at a glance, and
reasonably short. That is the kind of first-time impression
we need, not a 'wtf?' moment.

I just checked, there's zero hits on "git grep \<kstate_" in the
kernel, so it's a pristine namespace. IMHO, go wild ...

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/