Re: [PATCH 3/4] fix setuid sometimes wouldn't

From: Oleg Nesterov
Date: Sun Mar 29 2009 - 17:55:07 EST


On 03/29, Alexey Dobriyan wrote:
>
> On Sat, Mar 28, 2009 at 11:21:27PM +0000, Hugh Dickins wrote:
> >
> > -static struct fs_struct *get_fs_struct(struct task_struct *task)
> > +static int get_fs_path(struct task_struct *task, struct path *path, bool root)
> > {
> > struct fs_struct *fs;
> > + int result = -ENOENT;
> > +
> > task_lock(task);
> > fs = task->fs;
> > - if(fs)
> > - atomic_inc(&fs->count);
> > + if (fs) {
> > + read_lock(&fs->lock);
> > + *path = root ? fs->root : fs->pwd;
> > + path_get(path);
> > + read_unlock(&fs->lock);
> > + result = 0;
> > + }
> > task_unlock(task);
> > - return fs;
> > + return result;
> > }
>
> I think it's better to open-code. "root" parameter is unnatural.

IMHO, open-coding doesn't improve readability. I am not even talking
about code size (it doesn't matter of course, the kernel is so tiny ;).

Perhaps "enum what" is more natural compared to "bool root", but this
helper is simple enough.

Personally, I think this patch makes sense even if it didn't fix the
bug, it cleanups the code and makes it more readable.

Oleg.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/