[PATCH 1/2] tracing: use the more proper parameter.

From: Wenji Huang
Date: Thu Feb 12 2009 - 23:38:47 EST


Impact: clean up.

Rename tsk to next as Ingo suggested and pass it to
tracing_record_cmdline.

Signed-off-by: Wenji Huang <wenji.huang@xxxxxxxxxx>
---
kernel/trace/trace.c | 18 +++++++++---------
1 files changed, 9 insertions(+), 9 deletions(-)

diff --git a/kernel/trace/trace.c b/kernel/trace/trace.c
index 95f99a7..648df63 100644
--- a/kernel/trace/trace.c
+++ b/kernel/trace/trace.c
@@ -318,7 +318,7 @@ static raw_spinlock_t ftrace_max_lock =
* for later retrieval via /debugfs/tracing/latency_trace)
*/
static void
-__update_max_tr(struct trace_array *tr, struct task_struct *tsk, int cpu)
+__update_max_tr(struct trace_array *tr, struct task_struct *next, int cpu)
{
struct trace_array_cpu *data = tr->data[cpu];

@@ -328,15 +328,15 @@ __update_max_tr(struct trace_array *tr, struct task_struct *tsk, int cpu)
data = max_tr.data[cpu];
data->saved_latency = tracing_max_latency;

- memcpy(data->comm, tsk->comm, TASK_COMM_LEN);
- data->pid = tsk->pid;
- data->uid = task_uid(tsk);
- data->nice = tsk->static_prio - 20 - MAX_RT_PRIO;
- data->policy = tsk->policy;
- data->rt_priority = tsk->rt_priority;
+ memcpy(data->comm, next->comm, TASK_COMM_LEN);
+ data->pid = next->pid;
+ data->uid = task_uid(next);
+ data->nice = next->static_prio - 20 - MAX_RT_PRIO;
+ data->policy = next->policy;
+ data->rt_priority = next->rt_priority;

- /* record this tasks comm */
- tracing_record_cmdline(current);
+ /* record this task comm */
+ tracing_record_cmdline(next);
}

static void
--
1.5.6

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/