Re: [patch 2/6] epoll keyed wakeups v2 - introduce new *_poll()wakeup macros

From: Davide Libenzi
Date: Tue Feb 03 2009 - 15:24:22 EST


On Tue, 3 Feb 2009, Andrew Morton wrote:

> On Tue, 3 Feb 2009 11:20:46 -0800 (PST)
> Davide Libenzi <davidel@xxxxxxxxxxxxxxx> wrote:
>
> > On Tue, 3 Feb 2009, Davide Libenzi wrote:
> >
> > > On Tue, 3 Feb 2009, Andrew Morton wrote:
> > >
> > > > On Sun, 01 Feb 2009 12:04:23 -0800 Davide Libenzi <davidel@xxxxxxxxxxxxxxx> wrote:
> > > >
> > > > > +#define wake_up_nested_poll(x, m, s) \
> > > > > +do { \
> > > > > + unsigned long flags; \
> > > > > + \
> > > > > + spin_lock_irqsave_nested(&(x)->lock, flags, (s)); \
> > > > > + wake_up_locked_poll(x, m); \
> > > > > + spin_unlock_irqrestore(&(x)->lock, flags); \
> > > > > +} while (0)
> > > >
> > > > I had to go and find the callsite to work out the type of `x' :(
> > > >
> > > > - this macro can be passed the address of any structure which has a
> > > > `spinlock_t lock;' in it, which seems strange.
> > > >
> > > > - It references its first arg three times.
> > > >
> > > > Is there any reason why we can't implement this in C?
> > >
> > > I don't see any reason why these two couldn't be normal functions (I
> > > just referenced wake_up_nested(), that was a macro in the first place).
> >
> > Actually reading the comments helps :) It triggers an include-hell, if you
> > make them inline. Since they're lockdep debug thingies, I think it's kinda
> > wasted turn them into non-inline real functions, so they'd better remain
> > macros IMO.
> >
>
> ho hum. I think it'd be worth at least renaming the arguments to
> something less daft, for readability reasons.
>
> One could also do
>
> do {
> wait_queue_head_t *__wqh = x;
> <use __wqh>
> }
>
> which would provide typechecking of the first arg (so people can no
> longer "pass the address of any structure which has a `spinlock_t
> lock;' in it") and which fixes the multiple-references-to-an-argument
> issue.

OK, you've got my arg-rename bits already. Another version using a
typecheck() in there? Or you prefer the explicit instantiation?


- Davide


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/