Re: [PATCH] ring_bufer: fix BUF_PAGE_SIZE

From: Steven Rostedt
Date: Mon Dec 22 2008 - 13:37:27 EST




On Sun, 21 Dec 2008, Ingo Molnar wrote:
> * Lai Jiangshan <laijs@xxxxxxxxxxxxxx> wrote:

> > In the old codes, these lines confuse me:
> > return (addr & ~PAGE_MASK) - (PAGE_SIZE - BUF_PAGE_SIZE);
> > addr &= PAGE_MASK;
> > This patch mostly make the codes concordant.
>
> ah, okay. Steve, any strong feelings against the patch? And we might just
> go for removing BUF_PAGE_SIZE itself instead.

I'll need to rename BUF_PAGE_SIZE to BUF_SIZE since it is really the size
of a buffer per page. The pages will now have some header information on
it to let things like splice take the page away and still be able to
translate what is on the page.

-- Steve

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/