Re: [PATCH] nommu: fix kobjsize() for SLOB and SLUB, v2.

From: Christoph Lameter
Date: Tue Jun 10 2008 - 14:30:29 EST


On Tue, 10 Jun 2008, Vegard Nossum wrote:

> Are you sure it shouldn't be virt_addr_valid()? If yes, can you please
> explain the difference? Thanks :-)

from include/asm-x86/page.h

#define virt_addr_valid(kaddr) pfn_valid(__pa(kaddr) >> PAGE_SHIFT)

#define virt_to_page(kaddr) pfn_to_page(__pa(kaddr) >> PAGE_SHIFT)


Yes virt_addr_valid is better to use. I was thinking too much using the
basic ops.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/