Re: [patch 13/15] vfs: utimes cleanup

From: Christoph Hellwig
Date: Mon May 05 2008 - 07:30:57 EST


On Mon, May 05, 2008 at 11:54:54AM +0200, Miklos Szeredi wrote:
> From: Miklos Szeredi <mszeredi@xxxxxxx>
>
> Untange the mess that is do_utimes()

A good idea to untangle this, but I'm not entirely happy with how it's
done.

utimes_need_permission is a good helper and fine with me.

utimes_common is a good idea aswell, but I'd rather take the permission
checks into it aswell, even if that means a little flag telling if
file->f_mode should be checked or vfs_permission().

do_fd_utimes sounds fine, but I don't like that name. do_futimes maybe?

and when the fd-side is sorted out the path side should probably be a
helper aswell. Then sys_utime/sys_utimes/arhc bits could call it directly,
with the initial check in do_utimes separated out into a helper ala
utimes_need_permission. do_utimes should probably become do_futimesat
at the point.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/