Re: [PATCH 2/11] x86: convert to generic helpers for IPI functioncalls

From: Linus Torvalds
Date: Tue Apr 22 2008 - 15:51:49 EST




On Tue, 22 Apr 2008, Ingo Molnar wrote:
>
> ok. In which case the reschedule vector could be consolidated into that
> as well (it's just a special single-CPU call). Then there would be no
> new vector allocations needed at all, just the renaming of
> RESCHEDULE_VECTOR to something more generic.

Yes.

Btw, don't get me wrong - I'm not against multiple vectors per se. I just
wonder if there is any real reason for the code duplication.

And there certainly *can* be tons of valid reasons for it. For example,
some of the LAPIC can only have something like two pending interrupts per
vector, and after that IPI's would get lost.

However, since the queuing is actually done with the data structures, I
don't think it matters for the IPI's - they don't need any hardware
queuing at all, afaik, since even if two IPI's would be merged into one
(due to lack of hw queueing) the IPI handling code still has its list of
events, so it doesn't matter.

And performance can be a valid reason ("too expensive to check the shared
queue if we only have per-cpu events"), although I$ issues can cause that
argument to go both ways.

I was also wondering whether there are deadlock issues (ie one type of IPI
has to complete even if a lock is held for the other type).

So I don't dislike the patch per se, I just wanted to understand _why_ the
IPI's wanted separate vectors.

Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/