Re: processor flags

From: H. Peter Anvin
Date: Thu Mar 27 2008 - 15:56:18 EST


Cyrill Gorcunov wrote:

And now I'm in confusion - the way of changing this code I see is the
following:

- or use additional #ifdef CONFIG_VM86 in code where VM_MASK is used
(that would be ugly IMHO)
- rename VM_MASK to say X86_EFLAGS_VM86 with that #ifdef remained
- rest VM_MASK as it is

How do you think?


I think what we should do is:

- Rename VM_MASK to X86_VM_MASK (it's x86-specific after all)
- Have:

#if CONFIG_VM86
# define X86_VM_MASK X86_EFLAGS_VM
#else
# define X86_VM_MASK 0 /* No V86 support */
#endif

-hpa
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/