Re: [patch 2/4] Add ARCH_SUPPORTS_OPROFILE

From: Sam Ravnborg
Date: Wed Nov 14 2007 - 16:52:55 EST


> >
> >
> > In the arch specific Kconfig file in a suitable place do:
> >
> > config SUITABLE_OPTION
>
> Since config KPROBES will already be used in the architecture
> independent Kconfig, I should find a different name for "config
> SUITABLE_OPTION". Would
>
> config KPROBES_SUPPORT
> select ARCH_HAS_KPROBES
>
> be ok ?

I should have been more specific here.

We do NOT want a dedicated config symbol just for this.
For x86 use X86
For arm use ARM
For sparc64 use SPARC64
For sparc use SPARC32

etc. you get the picture.

For x86 (where I spend a fair amount of time recently)
there are several candidates to be moved to such a select
list.
Only reason not to do it then was to keep changes minimal.

It would look like this:

config X86
select ARCH_HAS_KPROBES # yada yada
select ARCH_HAS_FOO # more yada yada

If you select an undefined symbol kconfig will warn you so keep
an eye out for this (among all the other warnings kconfig spits out).

arm uses this for the different boards as a good example.
But they do not have the common-prefix rule in place.

Sam
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/