Re: [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfomacros.

From: Ken'ichi Ohmichi
Date: Thu Sep 20 2007 - 01:29:19 EST



Hi Andrew,

Andrew Morton wrote:
> > On Fri, 14 Sep 2007 12:00:18 +0900 "Ken'ichi Ohmichi" <oomichi@xxxxxxxxxxxxxxxxx> wrote:
> >
>> >> [4/4] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros.
>> >> Old vmcoreinfo macros were defined as generic names SYMBOL/SIZE/OFFSET
>> >> /LENGTH/CONFIG, and it is impossible to grep for them. So these names
>> >> should be changed. This discussion is the following:
>> >> http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/0415.html
> >
> > I already had these patches, except for #4.
> >
> > Your email client is space-stuffing the patches, so I have to do s/^ / /g
> > to apply them. Please see
> > http://mbligh.org/linuxdocs/Email/Clients/Thunderbird and/or the
> > soon-to-be-merged Documentation/email-clients.txt

Sorry for wasting your time.
I changed my thunderbird's setting according to the above site.


> > I plan on folding all of
> >
> > add-vmcoreinfo.patch
> > add-vmcore-cleanup-the-coding-style-according-to-andrews-comments.patch
> > add-vmcore-add-nodemask_ts-size-and-nr_free_pagess-value-to-vmcoreinfo_data.patch
> > add-vmcore-use-the-existing-ia64_tpa-instead-of-asm-code.patch
> > add-vmcore-add-a-prefix-vmcoreinfo_-to-the-vmcoreinfo-macros.patch
> >
> > into a single patch for upstream.

Thank you for merging them into linux-2.6.23-rc6-mm1.
Additionally, could you merge the following patches to clean up
add-vmcoreinfo.patch ?

[PATCH 5/4] [-mm patch] Rename macros returning the size.
The #define SIZE() should be renamed STRUCT_SIZE() since it's always
returning the size of the struct with a given name. This would allow
TYPEDEF_SIZE() to simply become SIZE() since it need not be used
exclusively for typedefs. This idea is David Rientjes's.
http://www.ussg.iu.edu/hypermail/linux/kernel/0709.1/1964.html

[PATCH 6/4] [-mm patch] use the existing offsetof().
It is better that offsetof() is used for VMCOREINFO_OFFSET().
This idea is Joe Perches's.


Thanks
Ken'ichi Ohmichi

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/