Re: [Patch 09/16] Remove unnecessary kmalloc casts in the pcisubsystem.

From: Paul Mackerras
Date: Wed Aug 01 2007 - 00:02:45 EST


Greg KH writes:

> On Tue, Jul 31, 2007 at 06:20:29PM +0200, Andreas Schwab wrote:
> > Greg KH <gregkh@xxxxxxx> writes:
> >
> > > On Tue, Jul 31, 2007 at 10:46:19PM +0800, WANG Cong wrote:
> > >> However, I think using resource_size_t is a bit better than unsigned long,
> > >> so that we don't need to check the defination of it.
> > >>
> > >> - res->start = (unsigned long)kmalloc(*size, GFP_KERNEL);
> > >> + res->start = (resource_size_t)kmalloc(*size, GFP_KERNEL);
> > >>
> > >> Is this change OK?
> > >
> > > Yes, that is the proper cast to have here.
> >
> > It will generate a warning when resoure_size_t is 64bit on a 32bit arch.
>
> How? And if so, what should the proper cast be?

You'll get a "cast from pointer to different-sized integer" type of
warning. The proper cast is unsigned long, just like the code is
without this patch. :)

Paul.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/