Re: RFC: kconfig select warnings bogus?

From: Satyam Sharma
Date: Sat May 19 2007 - 19:42:01 EST


On 5/20/07, Satyam Sharma <satyam.sharma@xxxxxxxxx> wrote:
On 5/20/07, Adrian Bunk <bunk@xxxxxxxxx> wrote:
> On Sun, May 20, 2007 at 04:47:52AM +0530, Satyam Sharma wrote:
> > On 5/20/07, Adrian Bunk <bunk@xxxxxxxxx> wrote:
> >> On Sun, May 20, 2007 at 04:19:12AM +0530, Satyam Sharma wrote:
> >> >...
> >> > A combined patch for all of those on top of 22-rc2 (adding
> >> Signed-off-by's
> >> > for original authors too):
> >> >...
> >> > --- a/arch/m68k/Kconfig 2007-05-20 04:11:47.000000000 +0530
> >> > +++ b/arch/m68k/Kconfig 2007-05-20 04:23:57.000000000 +0530
> >> > @@ -411,6 +411,7 @@ config STRAM_PROC
> >> >
> >> > config ATARI_KBD_CORE
> >> > bool
> >> > + default y if KEYBOARD_ATARI || MOUSE_ATARI
> >> >...
> >> > --- a/drivers/input/keyboard/Kconfig 2007-05-20 04:11:55.000000000
> >> +0530
> >> > +++ b/drivers/input/keyboard/Kconfig 2007-05-20 04:24:54.000000000
> >> +0530
> >> > @@ -167,7 +167,6 @@ config KEYBOARD_AMIGA
> >> > config KEYBOARD_ATARI
> >> > tristate "Atari keyboard"
> >> > depends on ATARI
> >> > - select ATARI_KBD_CORE
> >> > help
> >> > Say Y here if you are running Linux on any Atari and have a
> >> keyboard
> >> > attached.
> >> > diff -ruNp a/drivers/input/mouse/Kconfig b/drivers/input/mouse/Kconfig
> >> > --- a/drivers/input/mouse/Kconfig 2007-05-20 04:11:55.000000000
> >> +0530
> >> > +++ b/drivers/input/mouse/Kconfig 2007-05-20 04:25:09.000000000
> >> +0530
> >> > @@ -179,7 +179,6 @@ config MOUSE_AMIGA
> >> > config MOUSE_ATARI
> >> > tristate "Atari mouse"
> >> > depends on ATARI
> >> > - select ATARI_KBD_CORE
> >> > help
> >> > Say Y here if you have an Atari and want its native mouse
> >> > supported by the kernel.
> >> >...
> >>
> >> This is a good example how "fixing" the warnings makes things worse...
> >
> > How?
>
> Consider ATARI_KBD_CORE was used by 20 drivers.
>
> Using select for such not user visible helper variables is a really nice
> thing, and much more readable (and therefore much less likely to contain
> bugs) than dependencies with tons of "||"'s.

Well, the "default .. if .." kind of idiom is fairly common (I could say
almost standard), in arch/.../config's. It's been used for some time,
and for several symbols over there. But you're right that if 20 drivers
used ATARI_KBD_CORE, we'd get tons of ugly "||"'s there, so
perhaps we do need some kind of fix for this.

[ BTW ] I hope nobody gets the wrong message with the word "fix"
above, what you're pointing out is only a "readability" issue, not a
potential build breakage or any critical problem ...
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/