Re: [KJ][RFC][PATCH] BIT macro cleanup

From: Richard Knutsson
Date: Fri Feb 23 2007 - 13:16:25 EST

Dmitry Torokhov wrote:
I was not talking about name (I hate BITWRAP) but behavior.
Oh, my bad :)

but mainly since it only enables wrapping of the long-type.

I'd provde BIT and separate LLBIT for ones who really need long long.
People who intereseted in smaller than BITS_PER_LONG bitmaps shoud use
your proposal - BIT(x % DESIRED_WITH) and BIT should do modulo
BITS_PER_LONG internally.
I agree that _if_ there is a "BITWRAP" then it should be long, but I don't see the reason for it to be in bitops.h when it is only input.h that uses it. + I find it different with BIT since it works as well with 'char' as 'long'.
Also, I think it would be best if the name indicated it is a 'long'.

Am a little bit curious why you would like it in bitops.h, but won't complain if you do (think you have noticed my view of it ;))

Richard Knutsson

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at