Re: [PATCH 006 of 6] md: Add support for reshape of a raid6

From: Bill Davidsen
Date: Fri Feb 23 2007 - 10:52:29 EST

Andrew Morton wrote:
On Tue, 20 Feb 2007 17:35:16 +1100
NeilBrown <neilb@xxxxxxx> wrote:

+ for (i = conf->raid_disks ; i-- ; ) {

That statement should be dragged out, shot, stomped on then ceremonially

What's wrong with doing

for (i = 0; i < conf->raid_disks; i++) {

in a manner which can be understood without alcoholic fortification?

I don't find either hard to read, but you suggestion isn't equivalent, since it increments rather than decrements the index.
I admit I probably would write it the same way Neil did...

bill davidsen <davidsen@xxxxxxx>
CTO TMR Associates, Inc
Doing interesting things with small computers since 1979

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at