Re: Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)"to "array_for_each(index, array)"

From: Bernd Petrovitsch
Date: Tue Feb 13 2007 - 06:08:15 EST


On Tue, 2007-02-13 at 21:54 +1100, Nick Piggin wrote:
> Bernd Petrovitsch wrote:
> > On Tue, 2007-02-13 at 18:42 +1100, Nick Piggin wrote:
> >
> >>Joe Perches wrote:
> >
> > [...]
> >
> >>>perhaps:
> >>>
> >>>#define array_for_each(element, array) \
> >>> for ((element) = (array); \
> >>> (element) < ((array) + ARRAY_SIZE((array))); \
> >>> (element)++)
> >>
> >>If you're going for consistency, then shouldn't this be
> >>array_for_each_entry()?
> >
> >
> > That depends on the decision between consistency to array_for_each_index
> > or consistency to list_for_each.
>
> I don't follow.

Yes, thinko on my side. Sorry.

> list_for_each gives you a list_head.
> list_for_each_entry gives you a pointer to an entry in the list, which
> is equivalent to the above loop which gives a pointer to an entry in the
> array. Accordingly, it should be called array_for_each_entry. What sort
> of logic leads to another conclusion?

The wrong logic that list_for_each gives an entry. Sorry f.t. confusion.

Bernd
--
Firmix Software GmbH http://www.firmix.at/
mobil: +43 664 4416156 fax: +43 1 7890849-55
Embedded Linux Development and Services

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/