Coding style RFC: convert "for (i=0;i<ARRAY_SIZE(array);i++)" to"array_for_each(index, array)"

From: Joe Perches
Date: Mon Feb 12 2007 - 18:48:39 EST


Now that most of the sizeof(array)/sizeof(array[0])
conversions have been done (there are about 800 done
and about another 130 left), perhaps it could be
useful to change the code to use a define similar
to the list_for_each

#define list_for_each(pos, head) \
for (pos = (head)->next; prefetch(pos->next), pos != (head); \
pos = pos->next)

perhaps

#define array_for_each(index, array) \
for ((index) = 0; (index) < ARRAY_SIZE((array)); (index)++)


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/