Re: [PATCH 2.6.20] isdn-capi: Use ARRAY_SIZE macro when appropriate

From: Philippe De Muyter
Date: Wed Feb 07 2007 - 16:02:24 EST


On Wed, Feb 07, 2007 at 09:41:00PM +0200, Ahmed S. Darwish wrote:
> On Tue, Feb 06, 2007 at 10:18:14PM +0100, Philippe De Muyter wrote:
> > On Tue, Feb 06, 2007 at 10:41:30PM +0200, Ahmed S. Darwish wrote:
> > >
> > > - for (i=nelem-1; i >= 0; i--) {
> > > + for (i = ARRAY_SIZE(procfsentries) - 1; i >= 0; i--) {
> >
> > I would write such decrementing loops as :
> >
> > for (i = ARRAY_SIZE(procfsentries); --i >= 0; ) {
> >
> > Long time ago, that produced better code. I did not check recently though.
> [...]
> > > - for (i=nelem-1; i >= 0; i--) {
> > > + for (i = ARRAY_SIZE(procfsentries) - 1; i >= 0; i--) {
> >
> > Same here
>
> Hi Philippe,
>
> Won't this hurt readability ?. I'm not a gcc guru anyway to have an
> opinion on such stuff :).

Personaly, I find it more readable, but that's a question of habit or a
matter of taste.

Philippe
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/