Re: lots of code could be simplified by using ARRAY_SIZE()

From: Robert P. J. Day
Date: Sat Dec 16 2006 - 08:14:16 EST


On Sat, 16 Dec 2006, Pavel Machek wrote:

> Hi!
>
> > there are numerous places throughout the source tree that apparently
> > calculate the size of an array using the construct
> > "sizeof(fubar)/sizeof(fubar[0])". see for yourself:
> >
> > $ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
> >
> > but we already have, from "include/linux/kernel.h":
> >
> > #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
>
> Hmmm. quite misleading name :-(. ARRAY_LEN would be better.

i suspect it's *way* too late to make that kind of change, given that
"ARRAY_SIZE" is firmly ensconced in countless places in the source
tree and that would be a major, disruptive change.

even *i* wouldn't try to promote that idea. :-)

rday
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/