Re: [PATCH] Turn rdmsr, rdtsc into inline functions, clarify names

From: Rusty Russell
Date: Sat Aug 05 2006 - 23:07:52 EST


On Sat, 2006-08-05 at 19:58 -0700, H. Peter Anvin wrote:
> Rusty Russell wrote:
> >
> > You mean the l and ll variants? The 64 bit variants are rdmsrl and
> > rdtscll, not to be confused with rdtscl, which returns the lower 32
> > bits. This confusion caused the x86_64 bug in gameport.c which the
> > patch comment mentioned (at least, seems to be a bug to me).
> >
> > See why I want to fix these names?
> >
> > So if you would prefer u64 rdtsc64(), u32 rdtsc_low(), u64 rdmsr64(int
> > msr), u32 rdmsr_low(int msr), I can convert everyone to that, although
> > it's a more invasive change...
>
> rdmsrl is really misnamed. It should have been rdmsrq to be consistent,
> and have rdmsrl return the low 32 bits.

I prefer the more explicit linux-style naming of rdmsr_low32/rdmsr64,
myself, even though this is x86-specific code. Noone has an excuse for
misunderstanding then...

Thanks!
Rusty.
--
Help! Save Australia from the worst of the DMCA: http://linux.org.au/law

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/