Re: [PATCH 4/4] Streamline generic_file_* interfaces and filemap cleanups

From: Nathan Scott
Date: Mon May 15 2006 - 18:56:36 EST


On Mon, May 15, 2006 at 03:42:40PM -0700, Andrew Morton wrote:
> Nathan Scott <nathans@xxxxxxx> wrote:
> > Any chance that could be renamed to something thats a bit clearer,
> > maybe generic_file_non_aio_read and generic_file_non_aio_write?
>
> I guess that logically, we should avoid the double-negative and use
> generic_file_sio_*.

"s" as in "sync"? But its not sync.

> I dunno if we want to be that logical though ;)

The real problem I guess is that "aio" isn't clear enough, as there
are different types of async io. Maybe generic_posix_aio_* versus
generic_file_aio_* - *shrug*, thats probably not much better really.
Pretty much anything would be better than do_sync_write (describing
buffered not-sync writes) though. :)

On Mon, May 15, 2006 at 03:47:15PM -0700, Badari Pulavarty wrote:
> You mean "left-in-pagecache-not-really-written-to-disk" synchronous ?

Heh - yes, thats the one (you have a contradiction in terms there -
if its the former, its not the latter ;)

> Yeah. I see it..
> I prefer, generic_file_aio_read_and_wait(),
> generic_file_aio_write_and_wait() - but

Well, yeah - maybe - getting a bit long winded, but thats possibly the
best option so far.

> I also have a small issue with the current do_sync_*() routines - if
> some one calls it
> without setting their ->aio_read()/->aio_write(), we panic. May be we

Hmm. I imagine the author of the fs code would quickly find out they'd
made that mistake though, and it'd fail in a fairly easily debuggable
way, so perhaps not really a big issue in practice.

cheers.

--
Nathan
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/