RE: Fix unlock_buffer() to work the same way as bit_unlock()

From: Christoph Lameter
Date: Wed Mar 29 2006 - 02:08:33 EST


On Tue, 28 Mar 2006, Chen, Kenneth W wrote:

> Nick Piggin wrote on Tuesday, March 28, 2006 6:36 PM
> > Hmm, not sure. Maybe a few new bitops with _lock / _unlock postfixes?
> > For page lock and buffer lock we'd just need test_and_set_bit_lock,
> > clear_bit_unlock, smp_mb__after_clear_bit_unlock.
> >
> > I don't know, _for_lock might be a better name. But it's getting long.
>
> I think kernel needs all 4 variants:
>
> clear_bit
> clear_bit_lock
> clear_bit_unlock
> clear_bit_fence
>
> And the variant need to permutated on all other bit ops ... I think it
> would be indeed a better API and be more explicit about the ordering.

How about clear_bit(why, bit, address) in order to keep
the variants down? Get rid of the smp_mb__*_xxxx stuff.




-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/