Re: [PATCH 1/5] sched-cleanup_task_activated.patch

From: Con Kolivas
Date: Fri Jan 13 2006 - 05:43:47 EST


On Friday 13 January 2006 21:28, Andrew Morton wrote:
> Con Kolivas <kernel@xxxxxxxxxxx> wrote:
> > +enum sleep_type {
> > + SLEEP_NORMAL,
> > + SLEEP_NONINTERACTIVE,
> > + SLEEP_INTERACTIVE,
> > + SLEEP_INTERRUPTED,
> > +};
>
> If you make these 1, 2, 4 and 8
>
> > +static inline int interactive_sleep(enum sleep_type sleep_type)
> > +{
> > + return (sleep_type == SLEEP_INTERACTIVE ||
> > + sleep_type == SLEEP_INTERRUPTED);
> > +}
>
> then this can be
>
> return sleep_type & (SLEEP_INTERACTIVE|SLEEP_INTERRUPTED);
>
> which would save, oh, about nothing.

Hah yeah I went for readability over one cycle. Change it if you care; I don't
mind :).

Cheers,
Con
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/