Re: [PATCH] s390 (9/9): no timer interrupts in idle.

From: Dipankar Sarma
Date: Thu Apr 29 2004 - 03:20:19 EST


On Thu, Apr 29, 2004 at 09:43:21AM +0200, Martin Schwidefsky wrote:
> > Looks good except that I am wondering if idle_cpu_mask should
> > really be called nohz_cpu_mask. That is what it is, after all.
>
> I don't thinks so. The idle_cpu_mask isn't dependent on the
> no hz timer feature. I think it would make sense to set the

Well, you own patch says this :)

> +/*
> + * In a system that switches off the HZ timer idle_cpu_mask
> + * indicates which cpus entered this state. This is used
> + * in the rcu update to wait only for active cpus. For system
> + * which do not switch off the HZ timer idle_cpu_mask should
> + * always be CPU_MASK_NONE.
> + */

IOW, idle_cpu_mask is relevant (as of now) only when the
hz timer is switched off.

> bits in idle_cpu_mask even on system that use the normal hz timer.
> The tricky part is to find a way to clear the bits again after
> a wakeup interrupt. This needs to be done before the interrupt
> function is executed, you can't do it in idle().

idle_cpu_mask does not really represent CPUs that are conventionally
called "idle", it represents the ones that have hz timer switched
off (in your patch). So, why not just call it nohz_cpu_mask ?
RCU doesn't need an idle cpu mask, it has its own mechanism
for detecting idle cpus, it just needs to know about the ones
that have hz timers switched off. If you call it nohz_cpu_mask,
then it would make sense to say that for systems which do not
switch off hz timer, nohz_cpu_mask will always be CPU_MASK_NONE.

Thanks
Dipankar
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/