Re: [PATCH] oops_in_progress is unlikely()

From: Pavel Machek
Date: Wed Sep 10 2003 - 10:31:54 EST


Hi!

> > > none of this patch seems to touch particularly performance critical code.
> > > Is it really worth adding these macros to every if statement in the kernel?
> > > There comes a point where readability is lost, for no measurable gain.
> >
> > Perhaps we should have macros ifu() and ifl(), that would be used as a
> > plain if, just with likelyness-indication? That way we could have it
> > in *every* statement and readability would not suffer that much...
>
> You've got to be kidding.

I'm pretty serious.

ifu (a==b) {
something();
}

looks better than

if (unlikely(a==b)) {
something();
}

sched.c alone probably would get more readable as a result of such
conversion...

[Okay, having it at every statement is prbably bad idea.]
Pavel
--
When do you have a heart between your knees?
[Johanka's followup: and *two* hearts?]
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/