Re: [PATCH] PARAM 2/4

From: Linus Torvalds (torvalds@transmeta.com)
Date: Sun Nov 17 2002 - 13:00:17 EST


On Sat, 16 Nov 2002, Rusty Russell wrote:
> MODULE_PARAM is misleading and wrong.

Why is MODULE_PARAM() misleading and wrong? I think it's a lot more
descriptive, and these things are "modules" whether they are actually
compiled in or not.

The MM layer is just "another module". Granted, you can't compile it out
of the kernel, but it has a specific set of things it does, and is clearly
not the same thing as the scheduler, which is it's own "module".

The fact that PARAM was already used as a name should have been a big hint
that the name is not specific or descriptive enough.

Also, can we please stop shouting? I'd much rather see

        module_param(debug, int, 0600)

than

        PARAM(debug, int, 0600)

(see, for similarities, "module_init()", "module_exit()" etc: you don't
need to shout to make a point, and "module_xxx()" is already the accepted
practice for something that works both for compiled-in and modular
objects).

                Linus

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/



This archive was generated by hypermail 2b29 : Sat Nov 23 2002 - 22:00:19 EST