Re: [PATCH][2.5] introduce list_move macros

From: Thunder from the hill (
Date: Mon Jun 10 2002 - 09:17:40 EST


On Sun, 9 Jun 2002, Mark Zealey wrote:
> I guess that should be:
> +#define list_move_tail(list,head) \
> You should enclose the ops in a do { ... } while(0) block too.

There was a "revisited" version just a short time later. Please complain
about that one ;-)


German attitude becoming        |	Thunder from the hill at ngforever
rightaway popular:		|
       "Get outa my way,  	|	free inhabitant not directly
    for I got a mobile phone!"	|	belonging anywhere

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to More majordomo info at Please read the FAQ at

This archive was generated by hypermail 2b29 : Sat Jun 15 2002 - 22:00:18 EST