Re: [PATCH] change name of rep_nop

From: David S. Miller (
Date: Mon Oct 08 2001 - 18:46:29 EST

   From: David Woodhouse <>
   Date: Tue, 09 Oct 2001 00:42:04 +0100

   But x86 isn't particularly interesting - it'd be useful to have a
   flush_dcache_range() which actually works across other architectures anyway.
The memory technology device case is weird, give it a solution
such as "asm/memdev.h".

> Regardless, the purpose of the cachetlb.txt interfaces is for the
> generic VM subsystem of the kernel. Nothing more.
   So they should probably have less misleading names, perchance including the
   letter 'v' and the letter 'm' somewhere? And they should _certainly_ have
   less misleading documentation. :)

Why? find_get_page says nothing about "page cache", but people
understand that is what it is used for.

The documention should be more specific, thats all.

Franks a lot,
David S. Miller
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Oct 15 2001 - 21:00:22 EST