Re: Inclusion of zoned inactive/free shortage patch

From: Linus Torvalds (
Date: Tue Jul 17 2001 - 23:55:30 EST

On Tue, 17 Jul 2001, Marcelo Tosatti wrote:
> > A single-zone parameter just looks fundamentally broken.
> The "zone" parameter passed to swap_out() means "don't unmap pte's mapping
> to pages belonging to not-under-shortage zones". It can (and it should) be
> replaced by a "zone_specific" parameter.


In fact, it should be replaced by a single bit.

Passing in a "zone *" and then using it purely as a boolean makes no

But that still makes me ask: why do you have that (misnamed, and
mis-typed) boolean there in the first place? Why not just unconditionally
have the "zone_shortage(page->zone)"?


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon Jul 23 2001 - 21:00:10 EST