Re: PATCH: rewrite of invalidate_inode_pages

From: Juan J. Quintela (
Date: Fri May 12 2000 - 08:30:07 EST

>>>>> "trond" == Trond Myklebust <> writes:

trond> Could you please look into changing the name of
trond> invalidate_inode_pages() to invalidate_pages_noblock() or something
trond> like that? Since NFS is the only place where this function is used, a
trond> change of name should not break any other code.

We was talking about that in IRC just now....
I will do the patch later today.

trond> The reason I think this is necessary, is that this is the second time
trond> the 2.3.x kernel is broken because somebody has misunderstood, and has
trond> added wait_on_page() functionality to the same function.
trond> Alternatively, please make sure that we add explicit comments to that
trond> effect.

In my last patch there are a comment indicating that, that if you want
to wail for the *locked* pages also, you need to call truncate inode
pages. I will study truncate_inode_pages and their use later today,
came here with a comment for the semantic of both functions, and
people can told me if they agree/disagree.

>> Notice: that will be my first trip to /proc land....

trond> Ugh. Sounds like an extremely complex "solution" to something which
trond> has not yet been demonstrated to be a problem.

I think the same. I will preffer to tune the number to be *not too
much time* and nothing else.

Later, Juan.

In theory, practice and theory are the same, but in practice they 
are different -- Larry McVoy

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon May 15 2000 - 21:00:20 EST