Re: PATCH: rewrite of invalidate_inode_pages

From: Linus Torvalds (
Date: Thu May 11 2000 - 17:22:15 EST

On 11 May 2000, Juan J. Quintela wrote:
> Linus, I agree with you here, but we do a get_page 5 lines before, I
> think that if I do a get_page I should do a put_page to liberate it.

No, "get_page()" really means "increment the usage count by one", and the
problem is that it is obviously completely neutral wrt the actual size of
the page.

What we _could_ do is to just for clarity have

        #define page_cache_get() get_page()

and then pair up every "page_cache_get()" with "page_cache_release()".
Which makes sense to me. So if you feel strongly about this issue..


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
Please read the FAQ at

This archive was generated by hypermail 2b29 : Mon May 15 2000 - 21:00:18 EST